import Foundation
let pattern = #" (\s*<\/p>\s*<p>){2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" <\/p><p>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)