# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)<\/\1>/<\2>\3<\/\2>/gm;t' <<< "<str name=\"name\">John</str>
<date name=\"year\">2021</date>
<arr name=\"food\">
<str>Pizza</str>
<str>Meat</str>
</arr>"