using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<(str|date|arr|int|long).*?=""(.+?)"">(.*?)</\1>";
string substitution = @"<\2>\3</\2>";
string input = @"<str name=""name"">John</str>
<date name=""year"">2021</date>
<arr name=""food"">
<str>Pizza</str>
<str>Meat</str>
</arr>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}