import Foundation
let pattern = #"(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<str name="name">John</str>
<date name="year">2021</date>
<arr name="food">
<str>Pizza</str>
<str>Meat</str>
</arr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\2>\3</\2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)