#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\1>"
Local $sString = "<str name="name">John</str>" & @CRLF & _
"<date name="year">2021</date>" & @CRLF & _
"<arr name="food">" & @CRLF & _
" <str>Pizza</str>" & @CRLF & _
" <str>Meat</str>" & @CRLF & _
"</arr>"
Local $sSubst = "<\2>\3</\2>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)