re = /(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)<\/\1>/m
str = '<str name="name">John</str>
<date name="year">2021</date>
<arr name="food">
<str>Pizza</str>
<str>Meat</str>
</arr>'
subst = '<\\2>\\3</\\2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result