# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\1>'
test_str = ("<str name=\"name\">John</str>\n"
"<date name=\"year\">2021</date>\n"
"<arr name=\"food\">\n"
" <str>Pizza</str>\n"
" <str>Meat</str>\n"
"</arr>")
subst = "<\\2>\\3</\\2>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.