const regex = new RegExp('(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\\1>', 'gm')
const str = `<str name="name">John</str>
<date name="year">2021</date>
<arr name="food">
<str>Pizza</str>
<str>Meat</str>
</arr>`;
const subst = `<\2>\3</\2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);