import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<(str|date|arr|int|long).*?=\"(.+?)\">(.*?)</\\1>";
final String string = "<str name=\"name\">John</str>\n"
+ "<date name=\"year\">2021</date>\n"
+ "<arr name=\"food\">\n"
+ " <str>Pizza</str>\n"
+ " <str>Meat</str>\n"
+ "</arr>";
final String subst = "<\\2>\\3</\\2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}