$re = '/(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\1>/m';
$str = '<str name="name">John</str>
<date name="year">2021</date>
<arr name="food">
<str>Pizza</str>
<str>Meat</str>
</arr>';
$subst = "<\2>\3</\2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;