use strict;
my $str = '<str name="name">John</str>
<date name="year">2021</date>
<arr name="food">
<str>Pizza</str>
<str>Meat</str>
</arr>';
my $regex = qr/(?s)<(str|date|arr|int|long).*?="(.+?)">(.*?)</\1>/mp;
my $subst = '<\\2>\\3</\\2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";