# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'(status)'\s:\s(\d+)/$1 : $2/;t' <<< "complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }"