re = /'(status)'\s:\s(\d+)/
str = 'complete: task = { \'status\' : 0, \'task\' : \'{ \'id\' : 9149263125397547267, \'process\' : \'A-SIGN\', \'in\' : \'/file/log4j-api-2.11.0.jar\' }\' }'
subst = '$1 : $2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result