// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'(status)'\s:\s(\d+)").unwrap();
let string = "complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }";
let substitution = "$1 : $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}