import Foundation
let pattern = #"'(status)'\s:\s(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 : $2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}