#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "'(status)'\s:\s(\d+)"
Local $sString = "complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }"
Local $sSubst = "$1 : $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)