use strict;
my $str = 'complete: task = { \'status\' : 0, \'task\' : \'{ \'id\' : 9149263125397547267, \'process\' : \'A-SIGN\', \'in\' : \'/file/log4j-api-2.11.0.jar\' }\' }';
my $regex = qr/'(status)'\s:\s(\d+)/p;
my $subst = '$1 : $2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";