const regex = /'(status)'\s:\s(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(status)\'\\s:\\s(\\d+)', '')
const str = `complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }`;
const subst = `$1 : $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);