using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(status)'\s:\s(\d+)";
string substitution = @"$1 : $2";
string input = @"complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}