$re = '/\'(status)\'\s:\s(\d+)/';
$str = 'complete: task = { \'status\' : 0, \'task\' : \'{ \'id\' : 9149263125397547267, \'process\' : \'A-SIGN\', \'in\' : \'/file/log4j-api-2.11.0.jar\' }\' }';
$subst = "$1 : $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;