package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'(status)'\s:\s(\d+)`)
var str = []byte(`complete: task = { 'status' : 0, 'task' : '{ 'id' : 9149263125397547267, 'process' : 'A-SIGN', 'in' : '/file/log4j-api-2.11.0.jar' }' }`)
var substitution = []byte("$1 : $2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}