#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[[^]\\]*(?:\\.[^]\\]*)*\]"
Local $sString = "[abc]" & @CRLF & _
"[1-9\n\t]" & @CRLF & _
"[ \t\]]" & @CRLF & _
"[\\\]]" & @CRLF & _
"[[\\\\\\\]]" & @CRLF & _
"The square brackets cannot be nested, by example in [[]], we want to match [[]." & @CRLF & _
"" & @CRLF & _
"Although, since a \] indicate an escaped bracket, we need to skip those. But a pattern such as \\] must be accepted. The following would not be matched." & @CRLF & _
"" & @CRLF & _
"[\]" & @CRLF & _
"[\\\]" & @CRLF & _
"[abc\\\]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")