// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[[^]\\]*(?:\\.[^]\\]*)*\]").unwrap();
let string = "[abc]
[1-9\\n\\t]
[ \\t\\]]
[\\\\\\]]
[[\\\\\\\\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.
[\\]
[\\\\\\]
[abc\\\\\\]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}