use strict;
my $str = '[abc]
[1-9\\n\\t]
[ \\t\\]]
[\\\\\\]]
[[\\\\\\\\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.
[\\]
[\\\\\\]
[abc\\\\\\]';
my $regex = qr/\[[^]\\]*(?:\\.[^]\\]*)*\]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}