$re = '/\[[^]\\\\]*(?:\\\\.[^]\\\\]*)*\]/';
$str = '[abc]
[1-9\\n\\t]
[ \\t\\]]
[\\\\\\]]
[[\\\\\\\\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.
[\\]
[\\\\\\]
[abc\\\\\\]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);