import re
regex = re.compile(r"\[[^]\\]*(?:\\.[^]\\]*)*\]")
test_str = ("[abc]\n"
"[1-9\\n\\t]\n"
"[ \\t\\]]\n"
"[\\\\\\]]\n"
"[[\\\\\\\\\\\\\\]]\n"
"The square brackets cannot be nested, by example in [[]], we want to match [[].\n\n"
"Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.\n\n"
"[\\]\n"
"[\\\\\\]\n"
"[abc\\\\\\]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")