const regex = new RegExp('\\[[^]\\\\]*(?:\\\\.[^]\\\\]*)*\\]', 'g')
const str = `[abc]
[1-9\\n\\t]
[ \\t\\]]
[\\\\\\]]
[[\\\\\\\\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \\] indicate an escaped bracket, we need to skip those. But a pattern such as \\\\] must be accepted. The following would not be matched.
[\\]
[\\\\\\]
[abc\\\\\\]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}