import Foundation
let pattern = #"\[[^]\\]*(?:\\.[^]\\]*)*\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[abc]
[1-9\n\t]
[ \t\]]
[\\\]]
[[\\\\\\\]]
The square brackets cannot be nested, by example in [[]], we want to match [[].
Although, since a \] indicate an escaped bracket, we need to skip those. But a pattern such as \\] must be accepted. The following would not be matched.
[\]
[\\\]
[abc\\\]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)