# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]+data-src=("[^"]+")[^>]*>/<img src=$1 data-src=$1>/gm;t' <<< "<img src=\"old.jpg\" data-src=\"new.jpg\">
<img data-src=\"new2.jpg\" src=\"old2.jpg\">"