$re = '/<img[^>]+data-src=("[^"]+")[^>]*>/m';
$str = '<img src="old.jpg" data-src="new.jpg">
<img data-src="new2.jpg" src="old2.jpg">';
$subst = "<img src=$1 data-src=$1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;