import Foundation
let pattern = #"<img[^>]+data-src=("[^"]+")[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="old.jpg" data-src="new.jpg">
<img data-src="new2.jpg" src="old2.jpg">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src=$1 data-src=$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)