const regex = /<img[^>]+data-src=("[^"]+")[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]+data-src=("[^"]+")[^>]*>', 'gm')
const str = `<img src="old.jpg" data-src="new.jpg">
<img data-src="new2.jpg" src="old2.jpg">`;
const subst = `<img src=$1 data-src=$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);