re = /<img[^>]+data-src=("[^"]+")[^>]*>/m
str = '<img src="old.jpg" data-src="new.jpg">
<img data-src="new2.jpg" src="old2.jpg">'
subst = '<img src=$1 data-src=$1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result