using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]+data-src=(""[^""]+"")[^>]*>";
string substitution = @"<img src=$1 data-src=$1>";
string input = @"<img src=""old.jpg"" data-src=""new.jpg"">
<img data-src=""new2.jpg"" src=""old2.jpg"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}