// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img[^>]+data-src=("[^"]+")[^>]*>"#).unwrap();
let string = "<img src=\"old.jpg\" data-src=\"new.jpg\">
<img data-src=\"new2.jpg\" src=\"old2.jpg\">";
let substitution = "<img src=$1 data-src=$1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}