package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<img[^>]+data-src=("[^"]+")[^>]*>`)
var str = `<img src="old.jpg" data-src="new.jpg">
<img data-src="new2.jpg" src="old2.jpg">`
var substitution = "<img src=$1 data-src=$1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}