#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "'([^'\s]+)'"
Local $sString = "Andrea's -Stays as is" & @CRLF & _
"Kids' - stays as is" & @CRLF & _
"'Kids' --> Kids" & @CRLF & _
"Ki'd's' --> Kids'"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)