re = /'([^'\s]+)'/
str = 'Andrea\'s -Stays as is
Kids\' - stays as is
\'Kids\' --> Kids
Ki\'d\'s\' --> Kids\''
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result