package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'([^'\s]+)'`)
var str = `Andrea's -Stays as is
Kids' - stays as is
'Kids' --> Kids
Ki'd's' --> Kids'`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}