using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'([^'\s]+)'";
string substitution = @"\1";
string input = @"Andrea's -Stays as is
Kids' - stays as is
'Kids' --> Kids
Ki'd's' --> Kids'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}