import Foundation
let pattern = #"'([^'\s]+)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Andrea's -Stays as is
Kids' - stays as is
'Kids' --> Kids
Ki'd's' --> Kids'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)