import re
regex = re.compile(r"'([^'\s]+)'")
test_str = ("Andrea's -Stays as is\n"
"Kids' - stays as is\n"
"'Kids' --> Kids\n"
"Ki'd's' --> Kids'")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)