const regex = /(d\/)([A-z0-9]+)(\?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(d\\\/)([A-z0-9]+)(\\?)', 'gm')
const str = `//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);