import Foundation
let pattern = #"(d\/)([A-z0-9]+)(\?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)