$re = '/(d\/)([A-z0-9]+)(\?)/m';
$str = '//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;