re = /(d\/)([A-z0-9]+)(\?)/m
str = '//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result