// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(d\/)([A-z0-9]+)(\?)").unwrap();
let string = "//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}