use strict;
my $str = '//www.youtube.com/embed/DmYK479EpQc?vq=hd720&rel=0';
my $regex = qr/(d\/)([A-z0-9]+)(\?)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";