package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<table.*>)(<td.*)`)
var str = `<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...`
var substitution = "$1<tr>$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}