re = /(<table.*>)(<td.*)/
str = '<table border="0" bgcolor="#FFFFFF"><td bgcolor=...
<table width="780"><td align=...'
subst = '$1<tr>$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result